CSS all pages

[SOLVED] MAP-Plugin not generating Map-Message in v3.0

  • jlp1029
  • jlp1029's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
More
1 year 2 months ago - 1 year 2 months ago #380 by jlp1029
jlp1029 created the topic: [SOLVED] MAP-Plugin not generating Map-Message in v3.0
When V2I-Hub v3.0 starts up on command line:
sudo /usr/local/bin/tmxcore/

The following output is shown in the terminal:
2018-Jun-26 08:00:55.404520	INFO	/home/minix-crc-admin/Documents/V2I-Hub-v3/src/tmx/TmxCore/src/logger.cpp, 115	Adding event log from 'MAP' --> Plugin registered
2018-Jun-26 08:00:55.418375	INFO	/home/minix-crc-admin/Documents/V2I-Hub-v3/src/tmx/TmxCore/src/Plugin.cpp, 141	<MAP> Setting plugin status: Running
[2018-06-26 08:00:55.428] Utils/src/PluginClient.cpp (159) - INFO   : Config Changed. MAP_Files: { "MapFiles": [ {"Action":1, "FilePath":"STOL_MAP.xml"} ] }
ConvertToJ2735r41::ConvertToJ2735r41 Constructor Called
Lane Number: 2
Connection Lane Number: 106
Connection Maneuver: 1
Connection Signal Group: 2
[........some output omitted..........]
Connection Lane Number: 107
Connection Maneuver: 4
Connection Signal Group: 4
Lane Number: 106
Lane Number: 107
Lane Number: 108
Lane Number: 109

R41 XML:
<MapData>
    <msgID>18</msgID>
    <msgIssueRevision>0</msgIssueRevision>
</MapData>
Creating Lane:2
 Maneuver [1] 10 [0] 0 
 Maneuver [1] 20 [0] 0 
 Maneuver [1] 40 [0] 0 
Added Lane Attributes
[........some output omitted..........]
Creating Lane:109
Added Lane Attributes
End of nodes
Eastern Node:0 3 2
Northern Node:0
Elevation Node:0
Width Node:0

R41 XML:
<MapData>
    <msgID>18</msgID>
    <msgIssueRevision>0</msgIssueRevision>
    <layerType><intersectionData/></layerType>
    <intersections>
        <IntersectionGeometry>
            <id>
                <id>1001</id>
            </id>
            <revision>1</revision>
            <refPoint>
                <lat>389549970</lat>
                <long>-771493860</long>
            </refPoint>
            <laneWidth>305</laneWidth>
            <laneSet>

Which to us lead us to believe that the plugin is trying to generate the data and there may be an error occurring after or during that process, potentially due to the configuration.

The MAP_File configuration is the default value, with the default file STOL_MAP.xml, that has <J2735.GID.blob> tags. We have also experimented with different file type configurations with no luck.

We know we have to configuration for the DSRC radio plugin is working because we notice packets being sent over wireshark from the V2I IP address to the target IP in the plugin with packets that have "version=0.7 type=SPAT" embedded in them. (We noticed the opposite functionality on an earlier v2.5 build where we saw "type=MAP" but no SPAT messages)

We are also seeing through the web portal that the SPAT plugin is creating J2735 messages and the count increases steadily, however the only messages that the MAP plugin is generating are system keep alive messages.

We moved the STOL_Map file into the MAP plugin directory and tried changing the file permissions so that www-data was given owner and group permissions.

EDIT: The provided STOL_Map.xml file we are still unable to get working, but a privately supplied .JSON map file we were able to validate it (was missing a bracket..) and get it working. We are now seeing the V2I Hub publish about 8 SPAT messages to every 1 MAP message. Also, when we re-initialize with the .JSON nothing like the code block I included above is output in the terminal, which may be helpful to track down this bug.
Last Edit: 1 year 2 months ago by jlp1029. Reason: wording

Please Log in or Create an account to join the conversation.

More
9 months 2 weeks ago #479 by talam
talam replied the topic: [SOLVED] MAP-Plugin not generating Map-Message in v3.0
Hi there,

You mentioned that you have a privately supplied .JSON map file that you were able to validate which got V2IHub to start generating the Map messages. Would you be able to provide that file? I am having trouble setting up TIM and MAP messages through V2IHub.

Thanks in advance!

Please Log in or Create an account to join the conversation.

Time to create page: 0.032 seconds
Powered by Kunena Forum